Follow

I’m having trouble using Khan Academy on Internet Explorer

On the 12th of January 2016, Microsoft stopped providing security updates for Internet Explorer 10. Khan Academy will begin to phase out support for IE 10. This means that in addition to the security risk of continuing to use IE 10 or earlier versions, chances are increased your user experience of Khan Academy will suffer. 

 

To ensure the best possible user experience with Khan Academy, please use Chrome or Firefox browsers, or ensure that Internet Explorer is up to date. 

 

September 7 2016

Was this article helpful?
13 out of 22 found this helpful
Have more questions? Submit a request

Comments